Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 01, 2025 - 19:00 CET
Scheduled
We will be releasing a new version of the application - 25.11.2.1.
This release includes the following improvements and fixes: * Fixes a regression that could leave trips blocked after a failed PAO rail cancellation, ensuring that all rail segments are cancelled correctly and that hotel and car services can be cancelled as expected within the same booking * Minor fixes and improvements.
The application will be operational during the release.
Posted Dec 01, 2025 - 16:21 CET
This scheduled maintenance affected: Login/SSO, Travel, Travel API, Rail services, Air services, Car services, and Hotel services.