Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 20, 2026 - 12:45 CEST
Scheduled
We will be releasing a new version of the application - 26.4.1.5.
This release includes the following improvements and fixes: * Fixed a critical issue in the new Air UI where the traveler selection failed to reset for travel arrangers managing consecutive trip bookings.
The application will be operational during the release.
Posted May 20, 2026 - 12:05 CEST
This scheduled maintenance affected: Login/SSO, Travel, Travel API, Rail services, Air services, Car services, and Hotel services.