Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 10, 2025 - 20:30 CEST
Scheduled
As part of a scheduled system maintenance, car booking services will be temporarily unavailable for approximately one hour. We apologize for any inconvenience this may cause and appreciate your understanding.
Posted Jun 10, 2025 - 12:03 CEST
This scheduled maintenance affected: Car services.